2

While building anchor project, I faced the follow error:

"error: package `toml_edit v0.21.1` cannot be built because it requires rustc 1.69 or newer, while the currently active rustc version is 1.68.0-dev Either upgrade to rustc 1.69 or newer, or use cargo update -p [email protected] --precise ver where `ver` is the latest version of `toml_edit` supporting rustc 1.68.0-dev"

My current project is: rustc 1.75.0 (82e1608df 2023-12-21) anchor-cli 0.28.0 solana-cli 1.16.13

I tried solana-install init 1.16.13. But it didnt help me.

I am not sure what the reason and solution of this error.

My OS is ubuntu 22.04. Thanks

1 Answer 1

3

Try

solana-install init 1.18.1 

You may also need to upgrade to anchor 0.29.

Similar issue the 1.18.1 fixed here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.