1

I am trying to install anchor using avm install 0.29.0 but got the following error

error[E0635]: unknown feature `stdsimd`
  --> /Users/anhdungle/.cargo/registry/src/index.crates.io-6f17d22bba15001f/ahash-0.8.3/src/lib.rs:99:42
   |
99 | #![cfg_attr(feature = "stdsimd", feature(stdsimd))]
   |                                          ^^^^^^^

   Compiling rand_core v0.5.1
   Compiling rand v0.8.5
For more information about this error, try `rustc --explain E0635`.
error: could not compile `ahash` (lib) due to 1 previous error
warning: build failed, waiting for other jobs to finish...
error: failed to compile `anchor-cli v0.29.0 (https://github.com/coral-xyz/anchor?tag=v0.29.0#fc9fd6d2)`, intermediate artifacts can be found at `/var/folders/0h/tf8nh7sj20dgzt8dchfgzwj40000gn/T/cargo-installZHLWZm`.
To reuse those artifacts with a future compilation, set the environment variable `CARGO_TARGET_DIR` to that path.
Error: Failed to install 0.29.0, is it a valid version?

I have already run cargo update [email protected] and put ahash = "=0.8.8" into dependencies in Cargo.toml

2 Answers 2

1

Yes anchor 0.29.0 is a valid version.

You can install avm through

cargo install --git https://github.com/coral-xyz/anchor avm --locked --force

If the cargo fails, install the additional dependencies:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install -y pkg-config build-essential libudev-dev

then

avm install latest
avm use latest
0

In the end I managed to install anchor by downgrading from rustc 1.78.0-nightly to a stable version rustc 1.76.0 by rustup override set stable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.