3

I am adding quite a few solana related packages to an existing React-App I've been building and it seems one of the packages has a dependency that's breaking my UX.

error message

Anyone seen this error? It seems to have something to do with this dependency not being compatible with Webpack 5. I'm not even sure which of my packages has this dependency in the first place. These are all of the solana packages I'm adding:

"@babel/runtime": "^7.15.5",
"@civic/solana-gateway-react": "^0.7.0",
"@identity.com/solana-gateway-ts": "^0.8.1",
"@material-ui/core": "^4.12.3",
"@material-ui/icons": "^4.11.2",
"@material-ui/lab": "^4.0.0-alpha.60",
"@project-serum/anchor": "^0.17.0",
"@solana/spl-token": "^0.1.8",
"@solana/wallet-adapter-base": "^0.7.0",
"@solana/wallet-adapter-material-ui": "^0.13.1",
"@solana/wallet-adapter-react": "^0.13.1",
"@solana/wallet-adapter-react-ui": "^0.6.1",
"@solana/wallet-adapter-wallets": "^0.11.3",
"@solana/web3.js": "^1.33.0",
2

1 Answer 1

4

Seems like a missing transient dependency.

Consider installing it manually:

with npm:

npm i @ledgerhq/devices

with yarn:

yarn add @ledgerhq/devices

If this is a new react app, will advice you using one of these starters instead:

https://github.com/solana-developers/solana-dapp-next

https://github.com/solana-labs/wallet-adapter/tree/master/packages/starter

1
  • Does this worked ? Aug 12, 2022 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.