1

I have no issue deploying to testnet and devnet, but everything I've tried to get the program to deploy to mainnet using the CLI ends up with it hanging.

Has anyone deployed a program recently (April 2024) and have any tips?

I tried using --with-compute-unit-price but it didn't seem to make a difference.

3 Answers 3

2

Could just be due to network congestion

you'll also have to consider that Mainnet transactions might experience higher execution costs due to network activity. You can try using the 'solana fee calculator' command to get a more accurate fee estimate before deployment.

0

They generate the most recent prioritized-fee deployment commands here https://solana.gears.bot/deploy-cmd. Give it a try guys.

0

@Tu Phan --with-compute-unit-price and --max-sign-attempts arguments doesn't work any more. error: Found argument '--with-compute-unit-price' which wasn't expected, or isn't valid in this context.

New contributor
kadir is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.