1

Im setting up a standard env for Solana using NextJS/Typescript. When I try to add standard packages via Yarn:

yarn add @solana/wallet-adapter-react @solana/wallet-adapter-wallets @solana/web3.js @solana/wallet-adapter-react-ui

I then get multiple errors. Is this NextJS version related?

YN0002: │ @fractalwagmi/solana-wallet-adapter@npm:0.1.1 doesn't provide react (p30917), requested by @fractalwagmi/popup-connection ➤ YN0002: │ @fractalwagmi/solana-wallet-adapter@npm:0.1.1 doesn't provide react-dom (p5ab68), requested by @fractalwagmi/popup-connection ➤ YN0002: │ @solana-mobile/mobile-wallet-adapter-protocol-web3js@npm:2.1.3 [92141] doesn't provide react-native (p1b5b4), requested by @solana-mobile/mobile-wallet-adapter-protocol ➤ YN0002: │ @solana-mobile/wallet-adapter-mobile@npm:2.1.3 [93ed9] doesn't provide react-native (p55c0e), requested by @react-native-async-storage/async-storage ➤ YN0002: │ @solana/codecs@npm:2.0.0-preview.2 doesn't provide fastestsmallesttextencoderdecoder (p36ecc), requested by @solana/codecs-strings ➤ YN0002: │ @solana/wallet-adapter-particle@npm:0.1.12 [f33ed] doesn't provide bs58 (pc9a54), requested by @particle-network/solana-wallet ➤ YN0002: │ @solana/wallet-adapter-torus@npm:0.11.28 [f33ed] doesn't provide @babel/runtime (p5d8fb), requested by @toruslabs/solana-embed ➤ YN0002: │ @solana/wallet-adapter-trezor@npm:0.1.2 [f33ed] doesn't provide tslib (p7b33e), requested by @trezor/connect-web ➤ YN0002: │ @solana/wallet-standard-wallet-adapter-react@npm:1.1.2 [390ff] doesn't provide @solana/web3.js (p7b132), requested by @solana/wallet-standard-wallet-adapter-base ➤ YN0002: │ @solana/wallet-standard-wallet-adapter-react@npm:1.1.2 [390ff] doesn't provide bs58 (p9660b), requested by @solana/wallet-standard-wallet-adapter-base ➤ YN0002: │ @solana/wallet-standard-wallet-adapter-react@npm:1.1.2 [93ed9] doesn't provide @solana/web3.js (pe0ae3), requested by @solana/wallet-standard-wallet-adapter-base ➤ YN0002: │ @solana/wallet-standard-wallet-adapter-react@npm:1.1.2 [93ed9] doesn't provide bs58 (pc3263), requested by @solana/wallet-standard-wallet-adapter-base ➤ YN0002: │ @solana/wallet-standard-wallet-adapter@npm:1.1.2 doesn't provide @solana/wallet-adapter-base (p3d0d5), requested by @solana/wallet-standard-wallet-adapter-react ➤ YN0002: │ @solana/wallet-standard-wallet-adapter@npm:1.1.2 doesn't provide @solana/web3.js (pf9cc5), requested by @solana/wallet-standard-wallet-adapter-base ➤ YN0002: │ @solana/wallet-standard-wallet-adapter@npm:1.1.2 doesn't provide bs58 (p8299b), requested by @solana/wallet-standard-wallet-adapter-base ➤ YN0002: │ @solana/wallet-standard-wallet-adapter@npm:1.1.2 doesn't provide react (pba057), requested by @solana/wallet-standard-wallet-adapter-react ➤ YN0002: │ @trezor/connect@npm:9.2.2 [23d23] doesn't provide @babel/core (p50b41), requested by @babel/preset-typescript ➤ YN0002: │ @trezor/env-utils@npm:1.0.15 [cafdf] doesn't provide expo (p40e5a), requested by expo-constants ➤ YN0000: │ Some peer dependencies are incorrectly met; run yarn explain peer-requirements for details, where is the six-letter p-prefixed code

1 Answer 1

1

It looks like you might be missing some dependencies. According to https://github.com/anza-xyz/wallet-adapter/blob/master/APP.md#quick-setup-using-react-ui, you should run:

yarn add \
    @solana/wallet-adapter-base \
    @solana/wallet-adapter-react \
    @solana/wallet-adapter-react-ui \
    @solana/wallet-adapter-wallets \
    @solana/web3.js \
    react
1
  • Did this of course and same result. Except for react as that is built into nextjs. I do know it is a dependancy issue the question is why is Yarn responding in this way? nothing out of the ordinary in my setup.
    – dectral
    Commented May 3 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.