1

I tried to deploy my program to mainnet but i keep getting the following error.

Error: Error processing Instruction 3: invalid account data for instruction

i have allocated twice the size of program but still get the above error. I can deploy the program on devnet and localnet. I am wondering what might be the issue.

1
  • Could you add as much info as you have? Did a deploy fail before? Can you send the address of the buffer account? Which version did you use to delpoy? 1.18.12 with --use-rpc flag is the most reliable at the moment probably. It may be that its trying to reuse a buffer account or smth.
    – Jonas H.
    Commented May 6 at 13:55

1 Answer 1

2

Looks like you are using a syscall that is not activated on mainnet yet. Blake3.

You can see all used calls using:

 ~/.local/share/solana/install/active_release/bin/sdk/sbf/scripts/dump.sh solana_ibc.so output.txt

You can test it locally by disabling the feature thats not available.

solana-test-validator -r --deactivate-feature HTW2pSyErTj4BV6KBM9NZ9VBUJVxt7sacNWcf76wtzb3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.