I created a new file wallet using:

solana-keygen new --outfile ./new_wallet.json

Output of this command shows a pubkey and a seed phrase to save. I tried to import this output seed phrase into a wallet extension. When I entered this seed phrase, it showed like 100+ accounts to import and none of them was actual pubkey of created wallet. I confirmed it using:

solana-keygen pubkey ./new_wallet.json

The PublicKey output of this command, does not exist on seed phrase import. Then I tried importing wallet using private key, this works nicely. But seed phrase import points to completely different address. I am confused.

  • yeah, i'm also interested in this! I'm pretty sure it has to do with derivation paths and the CLI using a different one than the wallet extensions..
    – Solandy
    Aug 3, 2022 at 17:31

2 Answers 2


I elaborated the differences between CLI and common web wallet key derivation in this answer


It is because of derivations. For example you can read in the Phantom docs: https://docs.phantom.app/resources/faq#how-does-phantom-import-wallet-addresses

Send a small amount of Sol to the new wallet you just created and it will place it at the top of the list for importing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.