1

When I try to run anchor build in my terminal, this is the result I am getting in the terminal. I have uninstalled and installed rust but I am still getting the same output.

enter image description here

5
  • What version of Solana and anchor have you installed? Are you using WSL or Windows powershell?
    – Jimii
    Commented Jun 2 at 13:55
  • I use anchor version 0.30.0 and Solana version 1.18.15 I have tried both wsl and windows powershell. I am getting the same result. Commented Jun 3 at 22:47
  • could you try downgrading to 1.18.2 and anchor 0.29.0 and see if there are any differences
    – Jimii
    Commented Jun 4 at 15:28
  • I am still getting the same error. Commented Jun 5 at 1:46
  • Please use text instead of screenshots so other people can find your question.
    – mikemaccana
    Commented Jun 11 at 19:21

1 Answer 1

1

This looks like a bug in the typenum crate that you're using. You're using Windows, which doesn't allow for / in the paths, but the code is trying to include a file directly at https://github.com/paholg/typenum/blob/b237efbb1da9646435274f63d7290cb7651b031f/src/lib.rs#L72

You might need to fix that code to use a join instead, just like https://github.com/paholg/typenum/blob/b237efbb1da9646435274f63d7290cb7651b031f/build/op.rs#L20

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.