2

what should be the version of crates, since I am getting error of async-trait all time

    error: failed to select a version for the requirement `async-trait = "^0.1.77"`

The version details which would help me are:

solana-client, solana-sdk, solana-program, solana-program-test,

This is my cargo.toml file looks like right now and is generating build uptill now but further I add dependencies It causes me error in build

[package]
name = "abc"
version = "0.1.0"
description = "Created with Anchor"
edition = "2021"

[lib]
crate-type = ["cdylib", "lib"]  
name = "abc"

[features]
no-entrypoint = []
no-idl = []
no-log-ix-name = []
cpi = ["no-entrypoint"]
default = []

[dependencies]
anchor-lang = {version = "0.29.0", features = ["init-if-needed"]}
anchor-spl = "0.29.0"
solana-program = { version = "1.18.9", optional = true }

[dev-dependencies]
spl-token = { version = "^3.5.0", features = ["no-entrypoint"] }
num = "0.4.0"
async-trait = "0.1.52"
solana-sdk = "1.18.9"
spl-associated-token-account = "1.0.3"

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.