1

after deploy on localnet successful, run solana config set --url https://api.devnet.solana.com and config Anchor.toml

[programs.devnet]
counter = "58MKv4J4uWugtVvxfN2zgoVvUWAXUNLx8Qw9GQbnY4i3"

[provider]
cluster = "devnet"
wallet = "~/.config/solana/id.json"

Try many times, but still failed with this:

thread 'main' panicked at cli/src/program.rs:2809:26:

Should return a valid tpu client: PubsubError(ConnectionError(Io(Os { code: 104, kind: ConnectionReset, message: "Connection reset by peer" })))

New contributor
Hendry5479 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • I just tried deploy and it worked using anchor deploy on devnet. I use solana 1.18.17 and anchor 0.30.1. What are your versions?
    – Jonas H.
    Commented Jul 11 at 15:33

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.