2

I have run through the setup as provided here :

i get right to the end and then it fails to build - I am not an experienced developer -- tried to read around the problem..but can t get any solutions - yet....enter image description here

1
  • Please use text, rather than images of text, in your questions, that way other people can search and see your question. Nov 9, 2023 at 15:40

1 Answer 1

2

It seems like you don't have Solana installed locally on your machine.

Follow these steps to install: https://docs.solana.com/cli/install-solana-cli-tools#use-solanas-install-tool

Run this command in your terminal:

sh -c "$(curl -sSfL https://release.solana.com/stable/install)"

Alternatively, you can use the Solana playground which allows you to quickly develop, deploy and test Solana programs from the browser.

6
  • yes, you need to follow the install instructions on the link I posted in my answer
    – C.OG
    Aug 6, 2022 at 16:26
  • ok is there any way to install solana :gloablly" rather than just directory local -- I say this because - i followed your instructions and got a build -- but then made a mistake, so i went through the process again ....now I get the same error/!. does the solana instance get deleted every time I make a new init of anchor project...does that make sense? Aug 6, 2022 at 16:40
  • 1
    It makes sense, but the command is actually a global install. It may be that its not part of your path. Run the command again AND READ the last few lines of the output, it might ask you to run another command to save solana to your path
    – C.OG
    Aug 6, 2022 at 16:46
  • yes im gettin gfurther ahead with it... so thank you. I thought it would be a global install. However every time I go init a new project build it fails, and I have to reinstall the correct path - EACH TIME -- which is quite annoying... but hey ho Aug 6, 2022 at 18:30
  • Thats quite strange, something must be going wrong somewhere. I don't think you're adding solana to your path
    – C.OG
    Aug 6, 2022 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.