2

The project I'm working on has been hijacked and rugged by the ex-developer who had the authority account. Long story-short, he minted new tokens, then he emptied the liquidity pool.

We still have the owner account so I tried to change the authority wallet, but it failed with this error:

RPC response error -32002: Transaction simulation failed: Error processing Instruction 0: custom program error: 0x4 [5 log messages]

This is the CLI line I used for trying to change the mint authority:

spl-token authorize Token_Address mint New_Authority_Address

I looked up the 0x4 error and it looks like it means "/// Owner does not match." But this is not true. Running "spl-token account-info token_address" shows our wallet as the Owner.

I also tried running "spl-token revoke token_account_address" but it returns:

No delegate on account

Does anyone know how I can update the authority account?

1 Answer 1

2

No delegate on account means that there is no delegate to revoke on the token account.

spl-token authorize Token_Address mint New_Authority_Address would fail with Owner does not match because whatever mint you're trying to update is not owned by the address provided.

I would recommend transferring to a new token account and working from there. Assume anything else compromised.

1
  • The ex-developer&thief was the one who minted the old token. We created a new token eventually. I was hoping that we could somehow regain control of the old one to at least change its symbol and name. Thank you very much for your answer!
    – enki
    Aug 22, 2022 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.