0

So I didnt have AVX2 support in my WSL2 so I decided to clone and then compile the latest repo with the cargo-install-all.sh script. After all that when i run solana-test-validator i get this

Ledger location: test-ledger
Log: test-ledger/validator.log
⠁ Initializing...
Illegal instruction

Here is the validator log

[0m[38;5;8m[[0m2022-07-15T15:27:21.766890200Z [0m[32mINFO [0m solana_test_validator[0m[38;5;8m][0m Starting validator with: ArgsOs {
        inner: [
            "solana-test-validator",
        ],
    }
[0m[38;5;8m[[0m2022-07-15T15:27:21.767221600Z [0m[33mWARN [0m solana_perf[0m[38;5;8m][0m CUDA is disabled
[0m[38;5;8m[[0m2022-07-15T15:27:21.767271800Z [0m[32mINFO [0m solana_perf[0m[38;5;8m][0m AVX detected
[0m[38;5;8m[[0m2022-07-15T15:27:21.782079100Z [0m[32mINFO [0m solana_faucet::faucet[0m[38;5;8m][0m Faucet started. Listening on: 0.0.0.0:9900
[0m[38;5;8m[[0m2022-07-15T15:27:21.782179800Z [0m[32mINFO [0m solana_faucet::faucet[0m[38;5;8m][0m Faucet account address: BCpecVHpmjrebssHnt2aLrKiZLMAP6h9uirWKvRZ4qqR
[0m[38;5;8m[[0m2022-07-15T15:27:21.811610300Z [0m[1m[31mERROR[0m solana_ledger::blockstore[0m[38;5;8m][0m Unable to increase the maximum open file descriptor limit to 1000000 from 4096
[0m[38;5;8m[[0m2022-07-15T15:27:21.811699400Z [0m[32mINFO [0m solana_ledger::blockstore[0m[38;5;8m][0m Maximum open file descriptors: 4096
[0m[38;5;8m[[0m2022-07-15T15:27:21.811818500Z [0m[32mINFO [0m solana_ledger::blockstore[0m[38;5;8m][0m Opening database at "test-ledger/rocksdb"
[0m[38;5;8m[[0m2022-07-15T15:27:34.672767800Z [0m[32mINFO [0m solana_ledger::blockstore[0m[38;5;8m][0m "test-ledger/rocksdb" open took 12.9s```

2 Answers 2

0

Your validator log has a detailed description of the error.

I think it's better to use the current mainnet-beta/testnet version instead of top of the master. Use git checkout v1.9.29 before building, for example.

3
  • added the log, please see Commented Jul 15, 2022 at 17:28
  • That worked, looks like theres something wrong with the newer versions of solana cli Commented Jul 15, 2022 at 18:33
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jul 17, 2022 at 16:46
0

Did you uninstall the precompiled binaries first? Check that you're running the self-built binary with which solana-test-validator

1
  • Im fairly certain this was the newly compiled binary. The precompiled binary had a different error of "avx2 not supported, please compile binary yourself" or something along those lines. And I removed the old binaries from my path Commented Jul 15, 2022 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.