1

I have tried starting a local validator using solana cli command solana-test-validator. It works fine and starts from block 1 for localhost. But when I am following this doc: Starting a Validator and connecting to devnet/testnet validator, the log file shows the following errors

  • Received no response at tcp/8899, check your port configuration: timed out waiting on channel
  • Received no response at tcp/8900, check your port configuration: timed out waiting on channel
  • Received no response at tcp/9000, check your port configuration: timed out waiting on channel

As I have understood from the log file, this might have something to do with ports but i am not sure what exactly as all the incoming connections to all ports are open. So can anyone suggest a solution?

Edit: I need it running on devnet for testing purposes.

1 Answer 1

2

If you are on Linux/mac machine -> use this command to see if your port is already in use by any other process:

lsof -nPi | grep <PORTNUM> 

you can then kill the process that is using the port, or change the port that it uses and restart it!

NOTE: check if your host meets the devnet validator hardware requirements

Hope this helps!

1
  • No other process is using that port. I checked the processes after starting the validator and can confirm only solana validator is using those ports.
    – AjA
    Sep 26, 2022 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.