4

I am attempting to run the HelloWorld Solana program. I have cloned this repo. I have started the project with

solana-test-validator

I ran npm install and then was able to build the rust project with

npm run build:program-rust

I can see the .so file in the directory /dist/program/helloworld.so. When I try to deploy the program to Solana, I run

solana program deploy dist/program/helloworld.so

And here is the error I get

Error: Dynamic program error: No such file or directory (os error 2)

Although I have confirmed it is there, it cannot locate the file. I tried the entire path, but I still receive the same issue. The libs have been cleaned and reinstalled, however, that didn't help.

What should I attempt next?

2 Answers 2

3

A couple things to make sure of:

  1. The localhost (as opposed to devnet) is set via solana config set --url localhost

  2. You have generated a new keypair solana-keygen new

1
  • 1
    Thanks for the response..
    – Ramesh
    Sep 24 at 14:26
0

This will likely be Because your terminal's current working directory is not the parent directory of the dist Folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.