I'm using Fedora 36 for dev but I am having trouble running anchor test. I get the following output:

cargo-build-bpf child: /home/0xAckerman/.local/share/solana/install/active_release/bin/cargo-build-sbf --arch bpf
/home/0xAckerman/.rustup/toolchains/bpf/bin/cargo: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory

I found this similar question but none of the answers work for Fedora. In particular, I've tried

sudo dnf install lsb


sudo dnf install openssl-devel

which is basically libssl-dev for Fedora but it's already installed on my system. What am I missing?

2 Answers 2


I finally fixed it by downgrading to openssl1.1 using

sudo yum install openssl1.1

And anchor test finally works!


For Ubuntu users. I fixed it by installing the following lib.

Step 1: wget http://nz2.archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2.16_amd64.deb

Step 2: sudo dpkg -i libssl1.1_1.1.1f-1ubuntu2.16_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.