1

This is the error that appears when you run the NPM code for wallet adapter

From the solana cookbook (https://solanacookbook.com/getting-started/installation.html#install-web3-js), one is able to install web3.js and Spl token libraries via NPM, but can't do so for wallet adapter.

3 Answers 3

3

See the guide for apps here: https://github.com/solana-labs/wallet-adapter/blob/master/APP.md

At minimum, you'll want @solana/wallet-adapter-base and usually @solana/wallet-adapter-wallets, but you'll also likely want @solana/wallet-adapter-react or one of the community-maintained UI framework libraries.

See https://github.com/solana-labs/wallet-adapter/blob/master/PACKAGES.md for all Wallet Adapter packages.

2

Try

npm i @solana/wallet-adapter-wallets

or if doesn't work out you clone directly from GitHub

1

You can also use this simple & easy-to-follow guide to follow the latest steps for integrating the wallet adapter in your dapp.

https://www.solanawalletadapter.xyz/

Hope it helps.

1
  • Hey @saumay this is both a duplicate answer and a single link to a guide. I'd recommend putting the actual answer here and then back linking as a resource
    – Jacob Creech
    Nov 23, 2023 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.