1

I am using anchor to deploy my program on devnet and deployment process got stuck (there is enough sol on my wallet).

anchor new test
anchor build
anchor deploy --provider.cluster devnet

Deploying workspace: https://api.devnet.solana.com
Upgrade authority: /root/.config/solana/id.json
Deploying program "tmp"...
Program path: /workdir/test/tmp/target/deploy/tmp.so...
⠙   0.0% | Waiting for next block, 176 pending...   [block height 162679095; re-sign in 200 blocks

Here is the transaction.

Is this got something to do with solana upgrade to verstion v1.13.4 on devnet that happend today?

2 Answers 2

0

Upgrade solana cli to v1.13.2:

sh -c "$(curl -sSfL https://release.solana.com/v1.13.2/install)"

Now you can deploy your programs with anchor:

anchor deploy --provider.cluster devnet
0

I have the same issue on solana-cli v. 1.9.29 Should I maybe downgrade the version to v1.13.2?

2
  • Answer for my question is YES, it works!
    – mategog
    Dec 1, 2022 at 15:37
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review Dec 6, 2022 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.