8

I am trying to start solana-test-validator, but it closes unexpectedly with blockstore error.

Error: failed to start validator: Failed to create ledger at test-ledger: blockstore error

How can I fix this?

8
  • Do you start validator as ./validator/solana-test-validator? Nov 22, 2022 at 10:32
  • Yes, but i also tried different locations. Nov 22, 2022 at 10:43
  • Do you have Rosetta installed btw? I cannot reproduce your issue on my mac (v12 and Rosetta is intalled) Nov 22, 2022 at 15:40
  • Yep, rosetta is installed :( Nov 22, 2022 at 18:22
  • I guess the problem is with macos v13 since for v12 it works. But I don't know how to check it out without installing Nov 23, 2022 at 16:26

3 Answers 3

23

There are multiple versions of the 'tape archiver' (tar) program.

MacOS comes with BSD tar by default:

% tar --help | grep bsdtar
tar(bsdtar): manipulate archive files

Which is a less popular version of tar than the GNU tar. solana-test-validator expects GNU tar.

There is an issue to resolve the GNU tar dependendency. In the meantime, you can work around this issue by replacing BSD tar with a GNU version.

If you haven't installed homebrew, do that first. Then run:

brew install gnu-tar
# Put this in ~/.zshrc 
export PATH="/opt/homebrew/opt/gnu-tar/libexec/gnubin:$PATH"

You will now have BSD tar installed.

And then re-run solana-test-validator

4
  • this fixed it for me!!
    – Dev Bharel
    Dec 14, 2022 at 5:27
  • I have gnu-tar in a different location. After adding export PATH="/usr/local/Cellar/gnu-tar/1.34_1/libexec/gnubin:$PATH" to ~/.zshrc it was fixed.
    – channa ly
    Dec 22, 2022 at 15:45
  • This also fixed it for me on MacOS Ventura 13.3.1 M1 with solana-cli 1.14.18 and rustc pinned to 1.65.0 using a rust-toolchain.toml May 25, 2023 at 23:27
  • this fixed my problem though the error log is different: 'Error: failed to start validator: Failed to create ledger at test-ledger: io error: Error checking to unpack genesis archive: Archive error: extra entry found: "._genesis.bin" Regular'
    – DiveInto
    Mar 23 at 9:47
1

I had the same problem

solana-test-validator --reset

worked for me

1

If you're facing the same error even after installing gnu-tar. Try removing the test-ledger folder rm -rf test-ledger and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.