1

I am having issues compiling my code. I keep getting the error that @wallet-standard/app cant be resolved in \node_modules\@solana\wallet-standard-wallet-adapter-base\lib\esm. How can I resolve this issue?

Full error:

ERROR in ./node_modules/@solana/wallet-standard-wallet-adapter-base/lib/esm/wallet.js 17:0-50
Module not found: Error: Can't resolve '@wallet-standard/app' in 'E:\Programming\...\node_modules\@solana\wallet-standard-wallet-adapter-base\lib\esm'

Here is my package.json:

{
"dependencies": {
    "@solana/pay": "^0.1.0",
    "@solana/wallet-adapter-base": "^0.9.19",
    "@solana/wallet-adapter-react": "^0.15.25",
    "@solana/wallet-adapter-react-ui": "^0.9.23",
    "@solana/wallet-adapter-wallets": "^0.19.8",
    "@solana/web3.js": "^1.70.1",
    "@strata-foundation/web3-token-auth": "^3.5.4",
    "bignumber.js": "^9.0.2",
    "react-dom": "^17.0.2",
    "webpack": "^5.75.0"
},
"scripts": {
    "prod": "npm run production",
    "production": "cross-env NODE_ENV=production node_modules/webpack/bin/webpack.js --config=node_modules/laravel-mix/setup/webpack.config.js",
    "dev": "npm run development",
    "development": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js",
    "watch": "npm run development -- --watch",
    "watch-poll": "npm run watch -- --watch-poll"
},
"devDependencies": {
    "cross-env": "^7.0.3",
    "laravel-mix": "^6.0.41",
    "resolve-url-loader": "^5.0.0",
    "ts-loader": "^9.2.6",
    "typescript": "^4.5.5",
    "vue-template-compiler": "^2.6.14"
}

}

1
  • Which command are you running when you get that error?
    – Callum M
    Commented May 9 at 20:11

1 Answer 1

0

try adding a .env file with NODE_ENV='production' or 'mainnnet'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.