3

I've been using spl-token multisig for quite a while, but recently it stopped working and I'm getting this error:

Client(PresignerError(VerificationFailure))

We checked everything 10 times, rotated BLOCKHASH owners, but still no success, maybe someone noticed that too?


(all members ran this echo and got same results, all spl-token, solana cli versions are the same 2.2.0 and 1.13.5)

echo $TOKEN_ADDRESS $TOKEN_ACCOUNT $PKM $PK1 $PK2 $BLOCKHASH $FEE $NONCE_ACCOUNT
E5ndSkaB17Dm7CsD22dvcjfrYSDLCxFcMd6z8ddCk5wp 88DiZe8HKzupoVozYvHYjcnxWdEG53xxhTzBLUEndz3L 5MogdgJwD5EHmVCXHHa4TFoj8p1PoCaK9PQ9qgfrRsPC 58HsLURgpJCWWNX1Nsayf2cPNQu4q1ThTjGRNkPNztNV 3bqTcsJPHxR59uTkBExjVS3Ytq1SkA4rQvHmAQL3DZVp DMAj6eBFcvjwZS4hZStjdNdoc4xM71caAKG79VefBR8X 3n594wQbTLY1yyZ6rgXn6avJNHeGCUiUaqPZR7ocUJXC 5ArZh4GKmZ8iGmrLc8oXBR6bDTjg7V2KwxUfoz2yfa4o

spl-token transfer $TOKEN_ADDRESS 150000 $TOKEN_ACCOUNT \
    --owner $PKM \
    --multisig-signer $PK1 \
    --multisig-signer $PK2 \
    --blockhash $BLOCKHASH \
    --fee-payer $FEE \
    --nonce $NONCE_ACCOUNT \
    --nonce-authority $FEE \
    --signer $PK1=2W8xg5HUVVXrqJeB1T6yFnFeyPCJv4jc7wysuzrzZuB8rmJuLq6bQsvUzSzy7cc6pbGSMpEkNTKsXVzD3kmmVstE \
    --signer $PK2=FnVL6DFTe8jCGymGRfaR5bs6nJBKTr6usRjakq3RGbWZRjaYuvAtayqPPiXXp7REirZcYZvdqR9oSMj354K8K2f \
    --signer $FEE=JyBB7Sn73G3xJAzY6dsYAoJ5crV2D19d5e8McuYDHCF5hJdh9iBXKKcvAmJsgFrhKgmhUERUVAdUfXgxg5dvWtU
4
  • 1
    What changed between when it stopped working and now?
    – mikemaccana
    Commented Dec 21, 2022 at 22:02
  • The problem rn is that CLI is trying to use the owner as a signer which doesn't make sense bcs it's a multisig PDA, the actual program doesn't require it so be a signer. It was all working OK before, but maybe in recent solana upgrades they broke something in software of solana or spl-token cli Commented Dec 22, 2022 at 16:13
  • 1
    I'd try and work out what version it worked on, then test each upggade looking at the release notes. "library X version 1.2.3 breaks when I run doThing()" is a good bug report.
    – mikemaccana
    Commented Dec 22, 2022 at 16:41
  • 1
    Can you provide the command and args that reproduce this issue?
    – Jon C
    Commented Dec 22, 2022 at 23:12

1 Answer 1

1

downgrading to the last stable version of the cli works - v1.13.7 seems to work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.