1
error: failed to select a version for the requirement `aho-corasick = "^1.0.0"`
candidate versions found which didn't match: 0.7.20, 0.7.19, 0.7.18, ...
location searched: crates.io index
required by package `regex v1.8.1`
    ... which satisfies dependency `regex = "^1.0"` (locked to 1.8.1) of package `anchor-attribute-access-control v0.27.0`
    ... which satisfies dependency `anchor-attribute-access-control = "^0.27.0"` (locked to 0.27.0) of package `anchor-lang v0.27.0`
    ... which satisfies dependency `anchor-lang = "^0.27.0"` (locked to 0.27.0) of package `solana-twitter v0.1.0 (/Users/roshanwazare/projects/solana-twitter/programs/solana-twitter)````

1 Answer 1

3

Hello Roshan I was just sitting with a very similar problem. For reference, I'm using a MacBook Pro 2020 with Ventura 13.3.1 installed.

The pitfall for me was that I installed a older version of solana-release with the command, sh -c "$(curl -sSfL https://release.solana.com/v1.9.5/install)".

However, reading the installation guide, I could see that I should have been installing version 1.15.2

Installing the newer version fixed the problem for me, I hope it helps you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.