I am currently trying to learn the basics of Solana Smart Contracts and therefore tried the hello world program. Because I am on Windows, I downloaded Ubuntu on WSL 2. I downloaded Solana-CLI v1.14.18 (also tried with the stable version v1.13.8), had git(v2.34.1) and node (v9.5.0) already installed and created a new directory I just called "Rust". There I cloned the project with git clone ....

I stepped in the directory and am now at jmv@JMV_Legion:~/Rust/example-helloworld. But now trying to run solana-test-validator doesn't work but instead exits with the log (took it from the validator.log):

[2023-05-22T21:29:34.129159283Z INFO  solana_test_validator] solana-validator 1.13.8 (src:43daa379; feat:1775889670)
[2023-05-22T21:29:34.129189090Z INFO  solana_test_validator] Starting validator with: ArgsOs {
        inner: [
[2023-05-22T21:29:34.129214568Z WARN  solana_perf] CUDA is disabled
[2023-05-22T21:29:34.129226601Z INFO  solana_perf] AVX detected
[2023-05-22T21:29:34.129229466Z INFO  solana_perf] AVX2 detected
[2023-05-22T21:29:34.133541082Z INFO  solana_faucet::faucet] Faucet started. Listening on:
[2023-05-22T21:29:34.133557854Z INFO  solana_faucet::faucet] Faucet account address: 7FmdVRjCXFm7z7znSgbmPQrgRQCko7WA2YupQfVEHGrc
[2023-05-22T21:29:34.141941064Z INFO  solana_ledger::blockstore] Maximum open file descriptors: 500000
[2023-05-22T21:29:34.141968907Z INFO  solana_ledger::blockstore] Opening database at "test-ledger/rocksdb"
[2023-05-22T21:29:34.744682542Z INFO  solana_ledger::blockstore] "test-ledger/rocksdb" open took 602ms
[2023-05-22T21:29:34.749639465Z INFO  solana_metrics::metrics] metrics disabled: SOLANA_METRICS_CONFIG: environment variable not found
[2023-05-22T21:29:34.750927182Z INFO  solana_metrics::metrics] datapoint: shred_insert_is_full total_time_ms=0i slot=0i last_index=2i num_repaired=0i num_recovered=0i
[2023-05-22T21:29:35.040554913Z ERROR solana_ledger::blockstore] tar stdout:
[2023-05-22T21:29:35.040589949Z ERROR solana_ledger::blockstore] tar stderr: /bin/sh: 1: bzip2: Permission denied
    tar: test-ledger/genesis.tar.bz2: Wrote only 4096 of 10240 bytes
    tar: Child returned status 127
    tar: Error is not recoverable: exiting now

What do I need to do to solve this? I really would like to start but nothing has worked yet and I really am not experienced in Linux at all.


1 Answer 1


After re-downloading WSL, Solana, Rust and everything I found out that in WSL/Linux I need to go to the base root to have it executed.

So I hit cd ~ and then solana-test-validatorjust worked. I hope this will help someone who faces the same problems in the future!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.