0

error screenshotI am trying to build a new anchor project with boilerplate code. However, I am failing to do so and getting the error: error[E0658]: let...else statements are unstable

Anchor version: 0.27.0 OS: macOS Ventura 13.0

1

1 Answer 1

1

Can you try specifying your dependencies like this:

[dependencies]
         anchor-lang = "0.26.0"
         anchor-spl = "0.26.0"
         metaplex-token-metadata = { version = "0.0.1", features = ["no-entrypoint"] }
         solana-program = "=1.14.13"
         getrandom = { version = "0.2.9", features = ["custom"] }
         switchboard-v2 = "0.1.15"
         mpl-bubblegum = { version = "0.8.0", features = [ "no-entrypoint" ]}
         spl-account-compression = { version = "0.1.10", features = [ "no-entrypoint" ]}  

Just remove whatever deps you do not need from the above. Source and a link to the full discussion on the Solana gh issues page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.