2

I started receiving a strange error when trying to mint via Candymachine V2 on my mint page following the latest major version release of the Phantom Wallet (I believe this toe be v23.X).

The mint page used the official repo: https://github.com/metaplex-foundation/candy-machine-ui/tree/main/src

I was using the minting UI with CIVIC gatekeeper. Accepting the transaction to receive the CIVIC id token worked fine.

However, I am receiving the following errors when it proceeds to the actual mint-interaction:

1st: Transactions reverted during simulation

2nd: Once I Approve the above dialog the console returns the following 'Rejected via Websocket Error' indicating a concern with the instructions

3rd: The Solscan record appears to suggest 'Failing and Halting Here due to an extra unauthorized instruction'.

enter image description here

I investigated the instructions, and can't see how their construction differs from the candy-machine-ui. I spent hours sifting through the code and no idea what could be causing it.

Has someone experienced anything similar? Any pointers would be tremendously appreciated.

1 Answer 1

2

Unfortunately, it looks like CIVIC WAS the culprit.

I followed its implementation to the letter, both from the Metaplex and CIVIC documentation, and it just didn't work. Once CIVIC was taken out minting worked perfectly.

I arrived at this solution after someone helpful in the Metaplex chat suggested that they would recommend taking CIVIC out since they 'hadn't seen anyone use it for a long time'.

My recommendation to the Metaplex team - if I may - would be to see whether the team could repo the error and revisit the Metaplex Candymachine V2 documentation. I realize that Candymachine V2 was deprecated in favor for V3 but since collections have no clear path to upgrade to the new version it may be worthwhile to see whether said docs could be revisited if other projects are running into the same issues.

I would also recommend the same for the CIVIC team.

The issue started occurring with the Phantom upgrade to v23.X. Here phantom appears to inject additional instructions to the signable transactions, which isn't a problem during a normal mint, but causes issues when two sets of instructions need to be signed - like in the case of the CIVIC auth token.

While I am not exactly sure how, it appears that this workflow somehow breaks the number of instructions tokens that need to be included in the transaction before it gets signed, and the mint fails due to 'unexpected instructions'. I hope this helps anyone who runs into similar issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.