0

I have minted a collection and nfts using some codes, and got to same result than those other stackoverflow questions. Nfts are ok, collection is there, but solscan is not showing it in the NFT sheet.

Here some examples that I found in devnet with the same problem:

Source: How to verify a Metaplex collection?

Collection: https://explorer.solana.com/address/${collectionNft.mintAddress.toBase58()}/metadata?cluster=devnet

NFT: https://explorer.solana.com/address/${nftInCollection.mintAddress.toBase58()}/metadata?cluster=devnet

In the other hand, if I browse solscan, i found nfts with the collection reference under the royalty field: https://solscan.io/token/6CwTUkH4NCc9d34NSusPMhKz7jnZVSq16ZDZakkWfWZF

I have reviewed all metadata in those examples and the Reavers nft, and found no difference.

Any thoughts on that? Is it a problem of that those example NFTs just exists on Devent ? Is there any action to be performed on solscan ?

Thanks in advance !

2
  • is your collection verified ?
    – Effe2
    Sep 25, 2023 at 7:27
  • yes, it is ! at least its showing collection token and verified true in my nft metadata
    – Harlock
    Sep 25, 2023 at 14:58

1 Answer 1

0

The collection not showing on solscan is basically a problem with the explorer. It doesn't show collections on devnet. If you want to check if your code is correct try using https://translator.shyft.to/ explorer. Enter the wallet address that holds the NFT here and you should be able to see the collection your NFT is part of. Hope this helps!

1
  • 1
    Thanks Tushar, If solscan its not showing collections on Devnet problem is solved. This means it all works in mainnet ! Thanks
    – Harlock
    Sep 25, 2023 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.