2

Hello smart people of StackExchange,

I am currently playing arround with the new Token-2022, and i am attempting to create a token with Metadata directly in the mint account.

I am currently attempting using following CLI command:

spl-token --program-id TokenzQdBNbLqP5VEhdkAS6EPFLC1PHnBqCXEpPxuEb create-token --enable-metadata

And i recive this error:

error: Found argument '--enable-metadata' which wasn't expected, or isn't valid in this context
Did you mean --enable-permanent-delegate?

How do i solve this issue?

1
  • FIY: I have already dowloaded the newest version of spl-token-cli.
    – Sofus L
    Commented Nov 24, 2023 at 9:32

1 Answer 1

3

I faced the same issue and I had to update both spl-token-cli and solana tools to their latest versions https://docs.solana.com/cli/install-solana-cli-tools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.