0

I am trying to setup a solana-validator. And no matter what I did I could not get the rpc server running. Here is the command to run the validator

  --ledger /var/solana/data/ledger \
  --identity /var/solana/data/config/validator-keypair.json \
  --trusted-validator 7Np41oeYqPefeNQEHSv1UDhYrehxin3NStELsSKCT4K2 \
  --trusted-validator GdnSyH3YtwcxFvQrVVJMm1JhTS4QVX7MFsX56uJLUfiZ \
  --trusted-validator DE1bawNcRJB9rVm3buyMVfr8mBEoyyu73NBovf2oXJsJ \
  --trusted-validator CakcnaRDHka2gXyfbEd2d3xsvkJkqsLw2akB3zsN1D2S \
  --expected-genesis-hash 5eykt4UsFv8P8NJdTREpY1vzqKqZKvdpKuc147dw2N9d \
  --entrypoint entrypoint.mainnet-beta.solana.com:8001 \
  --entrypoint entrypoint2.mainnet-beta.solana.com:8001 \
  --entrypoint entrypoint3.mainnet-beta.solana.com:8001 \
  --entrypoint entrypoint4.mainnet-beta.solana.com:8001 \
  --entrypoint entrypoint5.mainnet-beta.solana.com:8001 \
  --no-voting \
  --snapshot-interval-slots 500 \
  --maximum-local-snapshot-age 500 \
  --gossip-port 8801 \
  --dynamic-port-range 8802-8815 \
  --no-port-check \
  --wal-recovery-mode skip_any_corrupted_record \
  --enable-rpc-transaction-history \
  --enable-cpi-and-log-storage \
  --init-complete-file /var/solana/data/init-completed \
  --snapshot-compression none \
  --require-tower \
  --no-wait-for-vote-to-start-leader \
  --no-poh-speed-test \
  --limit-ledger-size 50000000 \
  --accounts /var/solana/accounts \
  --full-rpc-api \
  --private-rpc \
  --rpc-bind-address 127.0.0.1 \
  --rpc-port 8799 \
  --log /home/solana/bin/log.txt

The validator is meant to run a rpc server at 127.0.0.1:8799 but when I run

sudo lsof -i -P -n | grep 8799

I get nothing. Is there something I am missing?

I tried using the --public-rpc-address flag and removing the ---private-rpc flag and I expected that the rpc server will be started.

1

1 Answer 1

2

Stop using --no-port-check and --no-poh-speed-test. Notify whoever you copied that from that they should stop recommending them.

Also, impossible to tell without looking at your logs.

The validator process will not start listening on the RPC port until it has caught up with the network, which is why lsof isn't showing anything.

You'll have to use solana-validator monitor to see the progress until then. In the log you posted, you can see it is still processing the snapshot, it hasn't even started the catchup process.

It can take anywhere from 20 minutes to an hour.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.