I need some help I'm new to solana development and I was following the Solana development course but ran into a lot of issues from the transactions part where packages I installed will no longer work and it I wouldn't be able to use web3.Keypair for example as web3 wouldn't be recognised. I haven't been able to progress. I then tried the solana bootcamp presented by Nick Frost on YouTube and faced more issues where I couldn't do npm i @/lib/vars and @/lib/helpers. I want to be able to code my own dApps in the future on the solana network. Furthermore, I've been struggling to install the solana CLI. Is there any chance where there is an updated course that I can learn from?

This is what happens with the CLI,

Copyright (C) Microsoft Corporation. All rights reserved.

Install the latest PowerShell for new features and improvements! https://aka.ms/PSWindows

PS C:\WINDOWS\system32> cmd /c "curl https://release.solana.com/v1.17.15/solana-install-init-x86_64-pc-windows-msvc.exe --output C:\solana-install-tmp\solana-install-init.exe --create-dirs"
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (35) schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certificate.
PS C:\WINDOWS\system32> C:\solana-install-tmp\solana-install-init.exe v1.17.15
  1.17.15 initialized

The HKEY_CURRENT_USER/Environment/PATH registry key has been modified to include:

Future applications will automatically have the correct environment, but you may need to restart your current shell.

Press the Enter key to continue.

PS C:\WINDOWS\system32> solana --version
solana : The term 'solana' is not recognized as the name of a cmdlet, function, script file, or operable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ solana --version
+ ~~~~~~
    + CategoryInfo          : ObjectNotFound: (solana:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

PS C:\WINDOWS\system32>

These are the course material I'm currently using, https://www.soldev.app/course & https://youtu.be/0P8JeL3TURU?si=cHWlvkwz2sFza5Tf

  • Hey! Would love to help you get these problems solved. Can you edit this post to add specific error messages that you're getting related to installing the CLI? Additionally, if you could also provide links to the course material you're working through that would help as well. Also: "@/lib/vars" and "@/lib/helpers" are not npm packages, but import aliases to files in the project. This means that if there's a repo link in the description, you should be able to find the contents of the corresponding files and copy them into your own project
    – Joey Meere
    Commented Jan 10 at 23:55

1 Answer 1


Once you clone the repo used in the video, you should be able to navigate to the directory, and run yarn install or npm i to install all of the needed packages. From there the variables and helpers included with the repo should work correctly. If the "web3" variable from @solana/web3.js is still not showing up, try restarting your IDE.

In terms of the Solana CLI issues, it's recommended to use Windows Subsystem for Linux (WSL) to run the Solana CLI properly. From there, you can run the following command to install the CLI:

sh -c "$(curl -sSfL https://release.solana.com/v1.17.15/install)"
  • 1
    OK I'll try that. Thanks for the response, will let you know how it goes
    – johnny
    Commented Jan 11 at 13:16
  • Everything's working now. Thanks for the help again
    – johnny
    Commented Jan 11 at 23:41
  • Glad it is all working @johnny! Since Joey answered the question, can you mark his answer as correct?
    – nickfrosty
    Commented Jan 12 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.