My image is not appearing in Phantom or Solscan. Metadata looks correct, image is an arweave link that works when searching. Any ideas why the image would not be displaying?


Are arweave links no longer supported or will it take time to populate?

2 Answers 2


Follow this tutorial to have best results https://awoyemivictor.notion.site/Latest-Solana-Token-Creation-Naming-Updating-Step-by-Step-Guide-for-Beginners-July-2022-fc2d8a4042ec49909047ba87eb3aa85a

  • or alternatively for above scenario you can upload image and metadata file to pinata and your logo will definitely show up. It worked in my case above guide is pretty detailed one. Commented May 4 at 18:59

Checking out your link, solscan still doesn't show the picture correctly, so I think it's unlikely that the problem is it taking that long to populate. Moreso, it seems Solscan is parsing it incorrectly, as can be seen by this screenshot. You can get to this page by clicking "View URI Metadata" on the "Metadata" page of your token.

enter image description here

For comparison, I found this other token here (NFA) that uses arweave for its token metadata as well. It's metada looks a lot more normal:

enter image description here

Looking at the arweave source, it looks mostly the same as yours, however there are a few differences, most notably it has an indent for each field of its metadata, which you do not. I'd assume this is the problem, but if it's not, I'm sure with this other token as a comparison and the "View URI Metadata" button it should now be easy for you to figure out what the root problem is with a little bit of trial and error :)

  • To whoever down voted this answer, please leave a comment on why, as I'm not sure what's wrong with my answer
    – Ahri
    Commented Jan 23 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.