Questions tagged [sendtransactionerror]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
14 views

SendTransactionError: Transaction results in an account (0) with insufficient funds for rent

Can someone please help me understand why I'm getting this error? I'm trying to perform this automatic transaction through websocket the moment the account receives any funds. I'm pretty sure the ...
lumplumbaum's user avatar
0 votes
0 answers
38 views

Custom program error 0x2e

I an trying to send a transaction to RAYDIUM V4 program to remove liquid from an Liquidity Pool. However, I encountered an error with code 0x2e. From here: https://github.com/raydium-io/raydium-amm/...
Bach Kim's user avatar
0 votes
1 answer
19 views

web3.js - Solana tx fails silently

I am using web3.js to send SOL txns, using the sendTransaction method. Sometimes, when I send a txn, the method will return me a transaction address. But when I look it up in solscan.io (even after 5 ...
01jayss's user avatar
  • 101
2 votes
1 answer
11 views

Unable to Utilize AnchorError in TS Tests

I should be able to test my errors against AnchorError codes in my TS tests (Ref), but when I run my tests are not working as expected and unable to recognize the AnchorError. Here's my snippet: ...
AMilz's user avatar
  • 1,381
0 votes
0 answers
15 views

Uncaught ReferenceError: Buffer is not defined | HTML, JS [closed]

at signInTransactionAndSendMoney ((индекс):214:27) at async sendButtonClick ((индекс):241:17) signInTransactionAndSendMoney @ (индекс):228 await in signInTransactionAndSendMoney (асинхронно) ...
yupigs's user avatar
  • 23
1 vote
2 answers
241 views

Solana sendRawTransaction & confirmTransaction ; confirmTransaction takes forever and fails

Allright I need help.. My Web3.js sign and send wouldn't work. I either get BlockHeightExceeded , Blockhash not found, or it just gets stucked in the confirmTransaction.. I have googled and looked ...
mesnia's user avatar
  • 13
0 votes
0 answers
35 views

{logs: Array(8) programErrorStack: em stack:failed to send transaction:failed to send transaction:Transaction Instruction 2:Program failed to complete

use anchor_lang::{ prelude::*, solana_program::{clock::Clock, hash::hash, program::invoke, system_instruction::transfer}, }; mod constants; mod error; use crate::{constants::*, error::*}; //...
Charbel Nakouzi's user avatar
3 votes
2 answers
689 views

How do I implement Jupiter's VersionedTransactions into Python?

I've been having a bit of trouble while trying to implement Jupiter's V4 swap API into my program. Although I haven't had any issues retrieving the transaction, I haven't figured out how to execute ...
OKprogrammer's user avatar
1 vote
1 answer
4k views

error while sending transaction with solanaweb3, [ReferenceError: Property 'Buffer' doesn't exist] in react native

the part of code that causes const connection = new Connection('https://api.testnet.solana.com'); console.log(privateKey, '+++++++++'); const feePayer = Keypair.fromSecretKey(bs58.decode(privateKey))...
Mian Bilal's user avatar
0 votes
0 answers
162 views

WalletSendTransactionError: Signature verification failed when minting NFT from Candy Machine

I am trying to add the capability for a user to be able to mint and NFT from a Candy Machine from the frontend of my website. I am running into this error when the user approves the mint transaction (...
xkycc's user avatar
  • 99
1 vote
1 answer
40 views

So when i Initialize i get a program error, It worked when i just created it without a txn confirmation

I tested the code without the sendandconfirmtxn and it worked, but then after deploying devnet it stopped working. this is my program #[program] pub mod solotesting2 { use super::*; pub fn ...
heheman's user avatar
  • 53
1 vote
1 answer
288 views

execute swap instruction using VersionedTransaction

i am trying to execute swap instruction using VersionedTransaction and i'm getting this error. const messageV0 = new TransactionMessage({ payerKey: payer.publicKey, recentBlockhash: blockhash, ...
devansh sanghvi's user avatar
1 vote
1 answer
283 views

Custom program error code 0x0 while sending a transaction

While trying to create a transaction containing as instructions the creation of a mint account, initialize mint instruction and ATA creation), it gives me the custom program error code 0x0 while ...
ASCorreia's user avatar
  • 243
1 vote
1 answer
133 views

invalid value: continue signal on byte-three, expected a terminal signal on or before byte-three when sending a transaction

I am trying to send a transaction signed via a web wallet, there is only one instruction to be executed which is to create an associated token pda. but i'm getting this response from rpc each time {&...
yohanes's user avatar
  • 41
1 vote
0 answers
352 views

Phantom Wallet blocking transactions that fail to simulate

Phantom seems to be completely blocking off transactions that are expected to fail on simulation. This is problematic for when trying to chain transactions where we want users to sign only once, but ...
Kurt's user avatar
  • 51
2 votes
2 answers
238 views

How can I sign a transaction with two signers?

I've got a program that is required to be signed by two signers. One signer is the account in my phantom wallet and the other is created in the code. const blockhash = await program.connection....
Discardo's user avatar
  • 121
9 votes
2 answers
2k views

IllegalOwner error: Provided owner is not allowed

I am having this error when processing instructions for a transaction. Detail error log: Transaction simulation failed: Error processing Instruction 1: Provided owner is not allowed Program ...
agentp's user avatar
  • 235
3 votes
2 answers
896 views

Calling one instruction after another results in Error: This account may not be used to pay transaction fees

I have two methods in my program, one to initialize a PDA and set some state variables the other to transfer SOL from one to another account pub fn initialize(ctx: Context<Initialize>, ...
mosmislit's user avatar
4 votes
2 answers
765 views

How to react to this RPC error as a dev: Node is behind by 166 slots

I was getting this error when sending a transaction to the RPC: Transaction failed: RPC response error -32005: Node is behind by 166 slots Why does this happen? How should we react to this error? ...
itsfarseen's user avatar
1 vote
2 answers
312 views

How to avoid SendTransactionError "This transaction has already been processed"

I'm writing an Anchor program which has an instruction that initializes a PDA account using some seeds. I want to write a test that verifies that my implementation ensures uniqueness: I can't call my ...
Callum M's user avatar
  • 2,827