Context: Ran the solana compressed nfts scripts successfully about 2 weeks ago from creating and minting to fetching by collection/owner using the helius devnet rpc endpoint.. This is the link to the compressed nft script: https://github.com/solana-developers/compressed-nfts

Problem faced: However, when I ran it yesterday, minting and creating of nfts works but not fetching by collection/owner. Instead, it returns the following error : enter image description here

Past solutions: I have tried re-running the scripts in the same order as well as checked on the api end point spec from metaplex repo but didnt find any breaking changes..

Ask: Is there any way to resolve this ?

1 Answer 1


The issue were running into was actually a bug in both the script repo you linked, as well as the RPC indexing code.

Specifically, with passing in a page=0 value.

The correct value for the page parameter is >0. So when using the getAssetsByGroup and getAssetsByOwner, the first page will start with index of 1.

I fixed the bug in the compressed nft repo you linked, and here is the closed issue from that repo as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.