3

Hi I am trying to call ctx.bumps.get("mint_account") on

#[derive(Accounts)]
#[instruction(params: CreateTokenParams)] pub struct CreateToken<'info> {
    /// CHECK: New Metaplex Account being created
    #[account(mut)]
    pub metadata: UncheckedAccount<'info>,

    #[account(
        init,
        seeds = [CONFIG_TAG],
        bump,
        payer = authority,
        space = std::mem::size_of::<TokenConfiguration>() + 8
    )]
    pub config: Box<Account<'info, TokenConfiguration>>,

    #[account(
        init,
        seeds = [b"<some phrase>"],
        bump,
        payer = authority,
        mint::decimals = 0,
        mint::authority = authority,
        mint::freeze_authority = authority,
    )]
    pub mint_account: Box<InterfaceAccount<'info, Mint>>,

    #[account(mut)]
    pub authority: Signer<'info>,

    pub rent: Sysvar<'info, Rent>,
    pub system_program: Program<'info, System>,
    pub token_program: Program<'info, Token2022>,

    /// CHECK: account constraint checked in account trait
    #[account(address = mpl_token_metadata::ID)]
    pub token_metadata_program: UncheckedAccount<'info>, }

but it is failing with below error enter image description here

What is wrong with this, why this is failing with get() method not found for CreateTokenBumps

I have also tried CreateTokenBumps but still getting the same error.

1
  • I faced the same issue and I resolved issue using this answer. it is very really helpful for me, thank you very much
    – Bheem Coin
    Jan 4 at 14:23

1 Answer 1

6

If you're using anchor-lang 0.29 (check the Cargo.toml file), the syntax for getting the bump has been updated.

Try using:

ctx.bumps.mint_account
1
  • thanks worked for me, I was using anchor-lang 0.29 only
    – blackhorse
    Jan 2 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.