0

I am trying to follow this tutorial https://www.soldev.app/course/intro-to-anchor, but when I tried to run anchor build I got:

BPF SDK: /Users/anhdungle/.local/share/solana/install/releases/1.9.4/solana-release/bin/sdk/bpf
cargo-build-bpf child: rustup toolchain list -v
cargo-build-bpf child: cargo +bpf build --target bpfel-unknown-unknown --release
    Updating crates.io index
error: failed to select a version for the requirement `regex = "=1.10.3"`
candidate versions found which didn't match: 1.8.4, 1.8.3, 1.8.2, ...
location searched: crates.io index
required by package `anchor-attribute-access-control v0.28.0`
    ... which satisfies dependency `anchor-attribute-access-control = "=0.28.0"` of package `anchor-lang v0.28.0`
    ... which satisfies dependency `anchor-lang = "=0.28.0"` of package `anchor-counter v0.1.0

although I have already installed [email protected] by cargo update [email protected]

4
  • Hey there did you installed anchor through AVM? Also what is ur avm v? Rust v ? Solana cli v and your cargo dependencies. Feb 11 at 21:32
  • Hi, yes, I installed anchor through avm. avm 0.29.0, rustc 1.76.0 (07dca489a 2024-02-04), rustup 1.26.0 (5af9b9484 2023-04-05), solana-cli 1.9.4 (src:8ce65878; feat:3258470607) ``` [dependencies] anchor-lang = "0.28.0" ``` Feb 11 at 23:56
  • 1
    Ok your solana cli is definitely outdated. Feb 12 at 1:37
  • Thanks, I updated it and it works now Feb 15 at 8:18

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.