From yesterday I haven't been able to deploy (upgrade) my program to solana mainnet. The deploy works fine on devnet, with the same binary. But when running solana program deploy on mainnet, it is stuck after a while, with the following message:

 1.7% | Sending 199/905 transactions             [block height 234210965; re-sign in 0 blocks]  

This is very odd since the last time my deployment failed it actually did output Blockhash expired. 5 retries remaining or something along the line, but now it is stuck at 0 blocks forever. My account on explorer site shows only a couple of transactions sent (about 10 txns), while a successful deployment would send hundreds of transactions. I've tried upgrading the solana-cli to match the cluster version, even switching to another machine but it didn't help. Does anyone have a workaround?

❯ solana --version
solana-cli 1.17.22 (src:da2078d4; feat:3580551090, client:SolanaLabs)

2 Answers 2


Try using the solana cli version v1.14.18

sh -c "$(curl -sSfL https://release.solana.com/v1.14.18/install)"

Then you can run the deploy command again, it seems to be faster than 1.16 and 1.17 https://github.com/solana-labs/solana/issues/32595#issuecomment-1682448390

I had the same issue and downgrading worked for me

  • Wow, I did exactly this and was able to deploy prior to reading your answer. Thanks anyway!
    – Kise
    Commented Mar 12 at 16:31

They generate the most recent prioritized deploy commands here https://solana.gears.bot/deploy-cmd . Let's have a look guys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.