Skip to main content

Questions tagged [installation]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2 votes
1 answer

403 Error when downloading Solana install tool

I am attempting to download the Solana CLI on my Ubuntu cloud server. Here is the download script I run: sh -c "$(curl -sSfL" When I do this, I ...
David Burca's user avatar
1 vote
1 answer

I am having problem in installing solana tool in my PC. ( windows 10 )

So, when i was using this following code while installing : C:\solana-install-tmp\solana-install-init.exe v1.16.14 Then I got the error showing "Your system cannot execute this program" or ...
Trygon's user avatar
  • 11
1 vote
1 answer

Node synchronization issues

I am currently running a Solana validator, but I've noticed that the ledger folder is increasing in size while the accounts folder remains at 28kb. Am I synchronizing incorrectly? I followed the ...
Solextra's user avatar
2 votes
1 answer

Error during installation

Installation fail of Solana CLI on Windows 11. Program 'solana-install-init.exe' failed to run: The file or directory is corrupted and unreadableAt line:1 char:1 + C:\solana-install-tmp\solana-install-...
Yasushiko's user avatar
1 vote
1 answer

Cannot install spl-token-sli - error[E0405]: cannot find trait `Signature` in crate `signature`

When I try to install spl-token-sli using command cargo install spl-token-cli. I get this error: error[E0405]: cannot find trait `Signature` in crate `signature` --> /home/marek/.cargo/registry/...
Mára Toner's user avatar
1 vote
3 answers

What's the best way to install solana wallet adapter?

From the solana cookbook (, one is able to install web3.js and Spl token libraries via NPM, but can't do so for wallet ...
Constructive Avidness's user avatar
1 vote
1 answer

Issues with installing solana on m1 mac book (macOS Monterey v12.6)

Followed guide to install solana as I was reading about issues installing with rosetta. But after running ./scripts/cargo-install-...
user2271's user avatar
1 vote
2 answers

Installing Anchor Failed -

I'm trying to install Anchor on my Unbuntu WSL Env. I'm getting this error. Would appreciate any guidence. $ avm install latest thread 'main' panicked at 'called `Result::unwrap()` on an `Err` ...
Drew F.'s user avatar
  • 11
2 votes
1 answer

I am having issues running anchor build command

I have run through the setup as provided here : i get right to the end and then it fails to build - I am not an experienced developer -- tried to read around the problem..but can t get any solutions -...
ross blytt jordens's user avatar
2 votes
1 answer

Anchor Installation Fails

I'm trying to install anchor on Ubuntu 22.04 but the installation fails. Here's the terminal output: cargo install --git avm --locked --force Updating git ...
Kirima's user avatar
  • 155